The DevTeam Alpha News Aggregation service has sourced the following article originally published on WP Engine:

Optimizing your WordPress site for speed and security is far from easy, but one simple step that can yield immediate results is making sure you’re running the most up-to-date version of Hypertext Preprocessor or PHP.

At WP Engine, we work hard to make sure our customers have access to the latest versions of PHP, and we typically make those versions available as soon as we’ve completed the necessary testing to ensure the coast is clear for all of our customers’ sites.

While we made PHP 7.3 available to all WP Engine customers after it was released last year (resulting in a 15% decrease in request processing time for customers across the board), we’ve now made PHP 7.4 available for all WP Engine customers who want to update.

Making the switch is easy—as always, our award-winning support team at WP Engine is ready to answer questions about upgrading to PHP 7.4, and if need be, they can help walk you through the process. However, if you want to perform the update on your own, it’s a simple process—just log in to your user portal and follow the steps outlined in this article.

Still have questions? Check out this helpful guide or log in to your account to contact support.

Why make the switch? 

There are a number of reasons to make the update to 7.4 now. While in general, running an up-to-date version of PHP will speed up your site (as mentioned above, the upgrade to 7.3 last year saw a significant speed increase for WP Engine customer sites) it also prevents hackers and other bad actors from taking advantage of security vulnerabilities that could be lurking in older PHP versions.

While no major security vulnerabilities have been flagged regarding PHP 7.3, it is considered a best practice to run the latest version of WordPress as well as up-to-date versions of components such as PHP. Just like any piece of software, older versions typically aren’t actively supported, so they aren’t guaranteed to be patched as quickly as newer ones. By updating to PHP 7.4 today, you can rest easy knowing your WordPress site is running the most up-to-date and secure version of the scripting language.

You’ll also make sure your site is among the top-performing websites in the WordPress ecosystem. Despite the well-known benefits of running the latest PHP version, the majority of WordPress users today are still using older, outdated versions. In fact, as seen in the graph below (from wordpress.org), nearly half of WordPress users are still using PHP version 7.0 or earlier.

A large group of WordPress users today still aren’t using the most recent version of PHP

A community effort

At WP Engine, we understand that low adoption of up-to-date PHP versions lessens the incentive for WordPress developers to utilize the latest version of PHP themselves—doing so would potentially alienate a large number of potential customers.

On the other hand, if the majority of WordPress users routinely updated their PHP versions, it would benefit WordPress and the WordPress community as a whole. A WordPress core proposal submitted last year advocates increasing the recommended PHP version for this very reason, and to raise awareness around the need to update PHP versions.

It’s certainly a valiant effort, and it’s yet another reason why WP Engine is committed to offering the latest version of PHP. Doing so not only allows our customers to take advantage of the best performance and security that WordPress has to offer, it males WordPress itself a better platform for all of its users.

Want to find out more about upgrading your PHP versions with WP Engine? Check out this customer testimonial, and as always, visit WP Engine to chat with a representative about any specific question you might have.

Learn more about WP Engine by visiting their website.